Lua 5.2 (work1) support

Coordinator
Jan 10, 2010 at 5:38 PM
Edited Jan 10, 2010 at 5:38 PM

Greetings everyone,

Lua 5.2 (work1) was released a few days ago and I wanted to share my thoughts on the matter.  Currently, the editor only supports the syntax as of Lua 5.1.4.  I've no plans to support older versions but am open to hearing any user feedback on the matter.  However, for future versions such as 5.2 (work1) and ultimately 5.2 when it is stable, I feel obligated to support them while maintaining backwards compatibility.  

My plan is to create an extra settings field which contains a drop-down to specify which version of the language you are using.  This is much trickier than it sounds as it will affect any future intellisense plans and auto-complete plans.  

Here are my current priorities in order:

  • Hidden Region/Brace Matching
  • Lua 5.2 (work1) support (drop-down settings feature and extra syntax)
  • Visual Studio 2010 support (both plugin and installer)

As always, any comments and suggestions are welcome :)

-Shaun