lua editor not showing up in VS2010

Jul 9, 2011 at 12:22 AM

I have Visual Studio 2010 Ultimate SP1.  I just installed you Lua Language Support.  However, when I try to edit a lua file, it is still looking like the Notepad editor.  Is there another step that I need to do besides installing your Lua Language Support?

Jul 12, 2011 at 11:09 AM

Hi, i ve got the VS 2010 professional edition with SP1 and i ve got the same problem. In the "Tools/Add-in Manager" or "Tools/Extension Manager" nothing shows up. Tools/options/texteditor doesn't offer a lua extension either.

Coordinator
Jul 12, 2011 at 3:05 PM

Hello,

Do you have any other extensions installed?

Try navigating to http://visualstudiogallery.msdn.microsoft.com/7af51f37-07ad-4d6b-9c2b-00672bb051ad?SRC=VSIDE and manually download the visual studio 2010 version installer for the plugin.

 

-Shaun

Jul 12, 2011 at 3:36 PM

I have a vanilla Visual Studio 2010 system.  the only add on is the Windows Phone 7 SDK and the Silverlight Tools.

Coordinator
Jul 12, 2011 at 3:46 PM

Do you see any errors or what not when the installer runs?

The only other thing I can think of is that the plugin does not work with SP1 as I haven't had the chance to test it with SP1 yet (other projects are preventing me from upgrading).  If needed, tonight I can install VS 2010 SP1 on a separate machine and test the plugin on that.

Jul 12, 2011 at 6:53 PM

I see no errors during the install.  It runs cleanly.  Is there any information that would be helpful to you?  Here is the information from the VS2010 About:

 

Microsoft Visual Studio 2010
Version 10.0.40219.1 SP1Rel
Microsoft .NET Framework
Version 4.0.30319 SP1Rel

Installed Version: Professional

Microsoft Office Developer Tools   01018-532-2002102-70172
Microsoft Office Developer Tools

Microsoft Visual Basic 2010   01018-532-2002102-70172
Microsoft Visual Basic 2010

Microsoft Visual C# 2010   01018-532-2002102-70172
Microsoft Visual C# 2010

Microsoft Visual C++ 2010   01018-532-2002102-70172
Microsoft Visual C++ 2010

Microsoft Visual F# 2010   01018-532-2002102-70172
Microsoft Visual F# 2010

Microsoft Visual Studio 2010 Team Explorer   01018-532-2002102-70172
Microsoft Visual Studio 2010 Team Explorer

Microsoft Visual Web Developer 2010   01018-532-2002102-70172
Microsoft Visual Web Developer 2010

Microsoft Windows Phone 7.1 Profiler   01018-532-2002102-70172
Microsoft Windows Phone 7.1 Profiler

Windows Phone SDK 7.1 (Beta2) - ENU   01018-532-2002102-70172
Windows Phone SDK 7.1 (Beta2) - ENU

Crystal Reports Templates for Microsoft Visual Studio 2010  
Crystal Reports Templates for Microsoft Visual Studio 2010

Microsoft Advertising SDK for Windows Phone 7   5.2.606.0

Microsoft Package Manager   1.0
Package Manager in Visual Studio

Microsoft Visual Studio 2010 Professional - ENU Service Pack 1 (KB983509)   KB983509
This service pack is for Microsoft Visual Studio 2010 Professional - ENU.
If you later install a more recent service pack, this service pack will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/983509.

Microsoft Visual Studio 2010 SharePoint Developer Tools   10.0.40219
Microsoft Visual Studio 2010 SharePoint Developer Tools

Microsoft XNA Game Studio   4.0
Microsoft XNA Game Studio 4.0
Build 4.0.30602.1

VisualStudioToolWindowHost   1.0
Information about my package

Windows Azure Tools   Version 1.3
Windows Azure Tools for Microsoft Visual Studio 2010 v1.3.31122.1601

Jul 14, 2011 at 7:12 PM

Have you made any progress on this issue?  Do you have any ideas or suggestions for me?  Is there any data that I can provide or tests that I can run for you?

 

Dick

Coordinator
Jul 14, 2011 at 10:44 PM

Sorry about the delay, ended up home sick for a couple of days.  I tested it on my home system that has SP1 installed and I was able to install it just fine.  I'm a bit stumped as to why it would not install correctly.

Jul 14, 2011 at 10:48 PM

I hope that you feeling better now.

 

Do you have any suggestions for me?

Coordinator
Jul 14, 2011 at 10:53 PM

One thing you can try doing is starting visual studio 2010 from the command line with logging enabled.  To do this, executed "devenv.exe /log".  For me, the location is "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe".

This link should give ya some more info - http://msdn.microsoft.com/en-us/library/ms241272.aspx

Hopefully the log can give us some insight as to why that package fails to load.

Jul 14, 2011 at 11:41 PM

I have the log but I do not see any errors in it.  Do you want to look at it?  If so, how can I send it to you?

 

Dick

Coordinator
Jul 14, 2011 at 11:50 PM

You can zip up the log and email it to me salec@salec.net

Jul 15, 2011 at 12:12 AM

It is on the way.

Coordinator
Jul 15, 2011 at 1:27 AM

I compared your log to mine and noticed that yours makes no mention to the plugin.  Can you check this path to see if you have any files?  The path might be slightly different as I'm running Windows 7 x64.

C:\Users\<username>\AppData\Local\Microsoft\VisualStudio\10.0\Extensions\Shaun Seckman\Lua Language\1.0

Jul 15, 2011 at 2:14 AM

I am also running Windows 7 x64.  In the C:\Users\<username>\AppData\Local\Microsoft\VisualStudio\10.0\ folder, there is no Extensions folder.

Jul 15, 2011 at 8:32 PM

I have previously tried installing this twice with the same result.  Would you like for me to try again?  If so, is there anything that I should watch for?

 

Dick

Oct 13, 2011 at 3:53 AM

I had the same problem when installing the msi.  I followed what rheuser said and installed it via the extension manager and I now see syntax highlighting.  thanks!

Oct 21, 2011 at 2:07 AM

I just used the Extensions Manager to install this and now it works great.  Thank you for the hint.

Sep 16, 2012 at 10:01 AM
Edited Sep 16, 2012 at 6:54 PM

Sorry to be late on this, I just did everything here and even uninstlal/reinstall via the extension manager doesnt fully do it for me.  .lua files get the little bomb icon on them, but a double click results in a "cannot open file", but file - open works (a pain to do that).

 

NEVERMIND.....my bad with the way I set up my project!